Donation Latency

Incident Report for GoFundMe Pro

Resolved

We have confirmed the fix in place has resolved the incident.
Posted Jul 31, 2026 - 20:01 PDT

Update

We are continuing to investigate the source of the latency issues. Meanwhile, our team has made adjustments to enhance the rendering process, so pages will now load as expected.
Posted Jul 31, 2026 - 20:00 PDT

Investigating

We are actively investigating reports of latency issues. This is not impacting transaction processing. Our team is investigating and will provide updates when available.
Posted Jul 31, 2026 - 19:49 PDT
This incident affected: GoFundMe Pro Manager (Campaign & Fundraising Pages).